TargetTalk

a place to talk about Olympic style shooting, rifle or pistol, 10 meters to 50 meters, and whatever is in between.
It is currently Fri Oct 24, 2014 3:48 pm

All times are UTC - 8 hours




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Thu Nov 05, 2009 1:48 pm 
Hello,

a friend of mine has a problem with his Hammerli in .22LR caliber. Maybe you could help him in solving this.

The problem is: pistol is shooting series ("doubles") on stronger ammuniton (no elaboration, stronger 'brand' or unequal, stronger single round).

As there are several of us using Hammerli SP20 RRS in .22 and .32 (separately for each caliber, with no conversion kits) we have already tried everything - changing parts and observing no change. This guy have changed whole trigger module, springs, recoil buffer.. We tried to "build on from two" guns with no success (still shooting doubles sometimes). Seemed to be better after exchanging the firing pin, but finally the problem still persist... when using stronger ammo ;-(

Have no idea what to do. Any piece of advice would be appreciated.

Rgrds,
zwz


Top
  
 
 Post subject:
PostPosted: Fri Nov 06, 2009 6:28 am 
Offline

Joined: Wed Dec 22, 2004 4:58 am
Posts: 108
Location: Ottawa Ontario Canada
You do not specifically mention that you tried exchanging his slide, which is a likely problem source since it contains the firing pin and also contacts the rim of the cartridge when returning into battery. It's so easy to do I bet you did, but still... you did try that?


Top
 Profile  
 
 Post subject: Double
PostPosted: Fri Nov 06, 2009 6:47 am 
I had a similar problem with my SP20, but mine would went to full auto. It started out doing doubles, but after awhile it went to full auto. Larry's Guns finally determined the head space on my bolt assembly was gone. He replaced he bolt assembly and the problem went away.


Top
  
 
 Post subject:
PostPosted: Fri Nov 06, 2009 12:36 pm 
Ed,

We've checked changing firing pin only as well as whole slide also. We've made so many tests that I don't remember all of them ;-) AFAIR the affected SP20 worked fine with parts from mine pistol... but I'm sure that the pistol of mine worked perfectly with any part from the affected one.
This is the reason that we haven't recognised any single part as the source of the problem.


Quest1,

I saw on this forum similar case described by randy1952 and jjgun, but as they've mentioned about "full auto" we hoped that it's not the same case as double-fires (they had to replace the barrels).

As english is not my mother tongue (and the "pistol language" is not commonnly used in work) I'm not sure what exactly have you had to raplace in your Hammerli.
Could you confirm whether the replaced part(s) were numbers 44, 48 from the manual? (like on page 3, could be found among others on http://stevespages.com/pdf/hammerli_sp20.pdf) or point out the correct ones.

Keeping my fingers crossed that it's something smaller and easier to change that the main parts of the pistol.


Top
  
 
 Post subject:
PostPosted: Fri Nov 06, 2009 2:53 pm 
Offline
User avatar

Joined: Sun Mar 27, 2005 11:48 pm
Posts: 809
Location: New Zealand
You need to recover some of the cases from the doubles to see if they have normal firing pin indentations in them.

If they have no firing pins indentations then it's probably headspace (too small will cause a slam fire).

If they have firing pin indentations, then check the firing pin is not sticking in the slide (also causing slam fires) and/or look for a cause of the hammer following the slide forward (this will be cause by trigger mechanism problems).

Also, try loading only one in the mag and fire it. Can you then dry fire the next? Or has the hammer followed the slide forward?


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 13, 2009 10:37 am 
j-team

We've done some test, but surprisingly we haven't noticed any double fires this time ;-?
In the beginning of our practise we have checked a lot of things including taking out the firing pin. Maybe we've inserted the conex pin (part 44/48 mentioned above) in a little different rotation and maybe this influenced better pistol behaviour...

It's good that there was no problem (hope to see this also on shooting conquests) but we've got no any cases from the doubles recovered ;-(

Firing pin (new one) is clear and not sticking in the slide. Firing mechanism (also changed to a new one) working correctly also.


Top
  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: Yahoo [Bot] and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group